Issue with getting back responses from the API Sunday 18th March 2018 14:06:00


Issue with getting responses from the API.

Issue was fixed